Librairie java pour usage de configuration yaml intégrant snakeyaml.

pom.xml 4.6KB

    <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd"> <modelVersion>4.0.0</modelVersion> <groupId>org.shortrip.boozaa.libs</groupId> <artifactId>YAMLConfiguration</artifactId> <version>1.0</version> <name>YAMLConfiguration</name> <repositories> <repository> <id>central</id> <name>Maven Repository Switchboard</name> <layout>default</layout> <url>http://repo1.maven.org/maven2</url> <snapshots> <enabled>false</enabled> </snapshots> </repository> <repository> <id>google-releases</id> <name>Google Releases</name> <url>https://oss.sonatype.org/content/repositories/google-releases</url> </repository> <repository> <id>shortrip-repo</id> <url>http://shortrip.org/maven</url> </repository> </repositories> <properties> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding> </properties> <build> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>2.0.2</version> <configuration> <source>1.5</source> <target>1.5</target> </configuration> </plugin> <plugin> <artifactId>maven-dependency-plugin</artifactId> <executions> <execution> <phase>install</phase> <goals> <goal>copy-dependencies</goal> </goals> <configuration> <outputDirectory>${project.build.directory}/lib</outputDirectory> </configuration> </execution> </executions> </plugin> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-shade-plugin</artifactId> <executions> <execution> <phase>package</phase> <goals> <goal>shade</goal> </goals> <configuration> <relocations> <relocation> <pattern>org.apache.commons</pattern> <shadedPattern>org.shortrip.boozaa.libs.commons</shadedPattern> </relocation> <relocation> <pattern>com.google.common</pattern> <shadedPattern>org.shortrip.boozaa.libs.commons</shadedPattern> </relocation> <relocation> <pattern>org.yaml.snakeyaml</pattern> <shadedPattern>org.shortrip.boozaa.libs.snakeyaml</shadedPattern> </relocation> <relocation> <pattern>javax</pattern> <shadedPattern>org.shortrip.boozaa.libs.javax</shadedPattern> </relocation> </relocations> </configuration> </execution> </executions> <configuration> <finalName>${project.artifactId}-${project.version}</finalName> </configuration> </plugin> </plugins> <resources> <resource> <directory>src/main/resources</directory> </resource> </resources> </build> <dependencies> <dependency> <groupId>org.yaml</groupId> <artifactId>snakeyaml</artifactId> <version>1.9</version> <type>jar</type> <scope>compile</scope> </dependency> <dependency> <groupId>com.google.guava</groupId> <artifactId>guava</artifactId> <version>10.0.1</version> <type>jar</type> <scope>compile</scope> </dependency> <dependency> <groupId>commons-lang</groupId> <artifactId>commons-lang</artifactId> <version>2.3</version> </dependency> </dependencies> </project>